Снегопат

Обсуждение Снегопата
Текущее время: 16 дек 2018, 10:28

Часовой пояс: UTC + 4 часа [ Летнее время ]




Начать новую тему Ответить на тему  [ Сообщений: 63 ]  На страницу 1, 2, 3, 4, 5 ... 7  След.
Автор Сообщение
 Заголовок сообщения: Кодогенераторы
СообщениеДобавлено: 09 дек 2011, 16:14 
Не в сети
Администратор

Зарегистрирован: 24 авг 2011, 17:04
Сообщения: 1917
Скриптом code_gen/gen_mgr.js начал делать инфраструктуру для различных генераторов кода.
Как пример - code_gen/create_doc.js - генерация болванки создания документа.

Накидывайте мыслей, что еще можно/хочется автоматизировать в плане генерации кода.
Такого, для чего возможностей шаблонов маловато.
Потому что основное отличие кодогенов от шаблонов - более интеллектуальное поведение.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогераторы
СообщениеДобавлено: 09 дек 2011, 18:33 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 17:36
Сообщения: 1077
Название темы поменяй :)
Цитата:
Кодогераторы


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 09 дек 2011, 21:53 
Не в сети

Зарегистрирован: 04 дек 2011, 11:36
Сообщения: 46
Откуда: Новосибирск
Вроде бы писал сюда. Не отправилось, что ли? ))
Нужно бы учитывать конфигурацию. Если типовая, то генерация кода соответствующая. С правильным использованием методов общих модулей.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 09 дек 2011, 22:22 
Не в сети
Администратор

Зарегистрирован: 24 авг 2011, 17:04
Сообщения: 1917
MaxS писал(а):
Вроде бы писал сюда. Не отправилось, что ли? ))
Нужно бы учитывать конфигурацию. Если типовая, то генерация кода соответствующая. С правильным использованием методов общих модулей.

А вот тут уже нужна некая экспертная база знаний, так сказать "путеводители" по разным типовым, да еще и по разным версиям типовых. Буду думать над этим.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 10 дек 2011, 09:53 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 17:36
Сообщения: 1077
MaxS писал(а):
Нужно бы учитывать конфигурацию. Если типовая, то генерация кода соответствующая. С правильным использованием методов общих модулей.

Пример приведи, пожалуйста.
Это заполнение данных по умолчанию чтоли?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 11 дек 2011, 21:12 
Не в сети

Зарегистрирован: 04 дек 2011, 11:36
Сообщения: 46
Откуда: Новосибирск
Скрипт ещё не успел глянуть. Он метаданные сможет создавать?
artbear писал(а):
Пример приведи, пожалуйста.
Это заполнение данных по умолчанию чтоли?


Толстый клиент, пример из формы документа РТУ , КА
Код:
   // Создать кнопки печати
   ФормированиеПечатныхФорм.СоздатьКнопкиПечати(ЭтотОбъект, ЭтаФорма);
КонецПроцедуры // ПриОткрытии()

Процедура ТоварыНоменклатураПриИзменении(Элемент)
   ПриИзмененииНоменклатурыТовары(Элемент);
КонецПроцедуры // ТоварыНоменклатураПриИзменении()


кстати, на толстый клиент наверное уже не стоит тратить усилия? ;)

Тот же документ, УФ. Там мелких типовых процедур, по моему ещё больше, чем в толстом.
Код:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
      
      // Это существующий документ.
      // Проверим, что его можно менять.
      НастройкаПравДоступа.ОпределитьДоступностьВозможностьИзмененияДокументаПоДатеЗапрета(РеквизитФормыВЗначение("Объект"), ЭтаФорма);

   КонецЕсли;


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 11 дек 2011, 23:38 
Не в сети
Администратор

Зарегистрирован: 24 авг 2011, 17:04
Сообщения: 1917
Не, скрипт не создает новый документ в метаданных.
Он генерит код для создания/заполнения реквизитов документа, т.е.
док = Документы.ТакойТо.СоздатьДокумент();
и т.д.
вот тут можно глянуть.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 14 дек 2011, 11:06 
Не в сети

Зарегистрирован: 24 авг 2011, 17:32
Сообщения: 709
При запуске конфигуратора вываливается предупреждение и сообщение об ошибке:
Цитата:
Скрипт D:\Programs\snegopat-alpha\scripts\code_gen\create_doc.js
В директиве $addin не указано имя аддина

содержимое addins.ini :
Код:
// Список загружаемых аддинов

script:scripts\code_gen\gen_mgr.js


Группа Проверка

   script:scripts\autosave.js
   script:scripts\vtcreator.js
   script:scripts\choiseParamType.js
   script:scripts\stg_autoconnect.js
   script:scripts\configCaption.js
   script:scripts\code_gen\create_doc.js

КонецГруппы


Группа Форматирование
   script:scripts\format.js
   script:scripts\textEditorExt.js
   script:scripts\VimComplete.js
   script:scripts\snippets.js
КонецГруппы

dll:SciColorerV8\SciColorerV8.dll

script:scripts\sc_clear.js
script:scripts\extfiles.js
script:scripts\queryParamsExtractor.js
script:scripts\extSearch.js


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 14 дек 2011, 12:50 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 17:36
Сообщения: 1077
Жень, в аддинс.ини нужно заносить только gen_mgr.js


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 14 дек 2011, 13:01 
Не в сети

Зарегистрирован: 24 авг 2011, 17:32
Сообщения: 709
Понял, спасибо.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 63 ]  На страницу 1, 2, 3, 4, 5 ... 7  След.

Часовой пояс: UTC + 4 часа [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB