Снегопат

Обсуждение Снегопата
Текущее время: 21 ноя 2019, 00:33

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 63 ]  На страницу Пред.  1, 2, 3, 4, 5, 6, 7  След.
Автор Сообщение
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 13:28 
Не в сети
Администратор
Аватара пользователя

Зарегистрирован: 24 авг 2011, 15:04
Сообщения: 1947
Это еще сто лет назад в семерке делалось, в intellisence :)
Надо и здесь добавить.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 13:31 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 15:53
Сообщения: 443
Откуда: Саратов
Так и было в опенконфе сделано, у меня сейчас есть уже набросок скрипта, который определяет тип переменных по префиксу переменной и выводит соответствующий список подсказок после точки, но список не родной - пока Александр не сделал возможности работать со списком и как-то его перехватывать. Т.е. для переменной тзДанные он определяет по наличию префикса "тз", что это таблица значений и т.п. Список префиксов редактируемый. Вообще настройка это пары "регулярное выражение" => "ИмяТипаданнных", т.е. можно настроить так, чтобы переменные с именами вроде СтруктураПараметров идентифицировались как Структуры, ТабДокПечать - как табличные документы и т.п.

По описанному же вами принципу планировал добавить и вторую эвристику для определения типа из комментариев.

Причешу на ближайших выходных код и выложу в общий доступ.

_________________
С уважением,
Александр Кунташов
https://plus.google.com/+АлександрКунташов


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 13:32 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 15:53
Сообщения: 443
Откуда: Саратов
Саш, а возможность перехватывать список подсказок, или что еще лучше было бы - модифицировать его перед показом, появилась? Или нет пока?

_________________
С уважением,
Александр Кунташов
https://plus.google.com/+АлександрКунташов


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 13:35 
Не в сети
Администратор
Аватара пользователя

Зарегистрирован: 24 авг 2011, 15:04
Сообщения: 1947
Скоро будет.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 13:43 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 15:53
Сообщения: 443
Откуда: Саратов
Вот как я кстати :) Ну значит постараюсь причесать код и закоммичу в паблик, а там думаю ребята быстро подхватят и помогут до ума довести )

Я сначала инлеллисенс хотел портировать, но оказалось, что там существенная часть кода отвечает за вычисление типов в выражении, а в Снегопате ты отличное API для работы с типами реализовал и эта часть существенно упрощается, поэтому решил переписать с нуля, дополнительно логически разделив часть кода, отвечающего за определение типа самой левой части выражения (исходной переменной) в отдельные эвристики (две написал выше), и часть, которая вычислением типа остальной части выражения занимается (учитывая все "точки" в выражении).

Благодаря этому можно будет управлять приоритетами (определять по префиксу или по комментарию с описанием типа например) или вообще отключать в настройках какие-то способы определения типа (например, отключить проверку типов по комментариям, если предпочитают использовать префиксы).

_________________
С уважением,
Александр Кунташов
https://plus.google.com/+АлександрКунташов


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 13:57 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 15:36
Сообщения: 1077
Саши :), ждем решения от обоих.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 18:22 
Не в сети

Зарегистрирован: 04 июн 2012, 09:28
Сообщения: 330
orefkov писал(а):
Скоро будет.

Я очень надеюсь, что можно будет не просто изменить состав списка, а и получить его содержание, а сам показ отменить.
Чтобы потом, например, показать свой список вместо стандартного.

Также напоминаю, что очень жду возможности отмены стандартной обработки шаблонов, добавленных Снегопатом - это которые Процедура/КонецПроцедуры и прочие.

_________________
В реальності все не так, як насправді


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 05 май 2014, 19:23 
Не в сети
Аватара пользователя

Зарегистрирован: 24 авг 2011, 15:36
Сообщения: 1077
Magister писал(а):
Я очень надеюсь, что можно будет не просто изменить состав списка, а и получить его содержание, а сам показ отменить.
Чтобы потом, например, показать свой список вместо стандартного.

Также напоминаю, что очень жду возможности отмены стандартной обработки шаблонов, добавленных Снегопатом - это которые Процедура/КонецПроцедуры и прочие.

+1 по обоим пунктам


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 06 май 2014, 09:26 
Не в сети

Зарегистрирован: 06 сен 2013, 07:59
Сообщения: 189
Не знаю, вроде многие используют для этого что-то вроде такого:
Если 1=0 Тогда
НоменклатураВход = Справочники.Номенклатура.СоздатьЭлемент();
КонецЕсли;

Просто надо подумать, как такие вещи удалять автоматом и добавлять (или просто комментарить раскомментарить)


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Кодогенераторы
СообщениеДобавлено: 06 май 2014, 10:47 
Не в сети

Зарегистрирован: 20 дек 2011, 10:31
Сообщения: 588
Откуда: Украина, Запорожье
Вроде правильней так.
#Если _ Тогда

#КонецЕсли;
не будет в принципе компилироваться.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 63 ]  На страницу Пред.  1, 2, 3, 4, 5, 6, 7  След.

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB